netzkompetenz

Snippets, Tipps und Tricks rund um Webprogrammierung der taywa gmbh aus Zürich

ve_guestbook für TYPO3 6.2

Ich habe ve_guestbook zu TYPO3 6.2 kompatible gemacht, hier zum Download:
ve_guestbook.zip

Ein Fix, damit das Frontend auch in Deutsch angezeigt wird, ist auch noch darin enthalten.

Im Zip-File hat es auch noch ein .git Folder, damit man nachvollziehen kann, was geändert wurde. Hier auf jedenfall das Diff: ve_guestbook.diff

Quellen:
http://www.shentao.de/2014/01/extension-veguestbook-mit-typo3-62-beta.html
http://webdesign-forum.net/thread-2886.html
https://jweiland.net/typo3/extension/gaestebuch-ve-guestbook.html

Orignal Extension ve_guestbook im TER http://typo3.org/extensions/repository/view/ve_guestbook

No tags for this post.
Posted by: Fabian Thommen on 30. April 2015 @ 14:22
Filed under: TYPO3,TYPO3 6.2,TYPO3 Setup,TYPO3 Upgrade

2 Comments »

  1. Hallo zusammen und vielen Dank für die Überarbeitung des Guestbooks für TYPO3 6.2!

    Installation und Einrichtung hat soweit alles funktioniert. Nach der Installation habe ich auch schon diverse Einträge in der Listenansicht vorgenommen.

    Doch plötzlich (ich weiß leider nicht seit welchem Schritt meiner Webseiten-Änderung) erhalte ich in der Listenansicht nur auf der Seite des Gästebuchs folgende Fehlermeldung (auf anderen Seiten funktioniert die Listenansicht):

    #1: PHP Catchable Fatal Error: Argument 1 passed to TYPO3\CMS\Core\Utility\ArrayUtility::mergeRecursiveWithOverrule() must be of the type array, null given, called in /is/htdocs/wp12420099_DLO3G0ZROO/www/meineseite/typo3/sysext/lang/Classes/LanguageService.php on line 452 and defined in /is/htdocs/wp12420099_DLO3G0ZROO/www/meineseite/typo3/sysext/core/Classes/Utility/ArrayUtility.php line 517

    Zudem kann ich auf allen Seiten kein neues Inhaltselement anlegen (der rechte Bereich wird dann grau), bearbeiten etc. funktioniert.

    Im Frontend funktioniert das Gästebuch aber weiterhin einwandfrei.

    Kennt jemand das Problem und noch wichtiger eine Lösung?

    Vorab vielen Dank!

    Kommentar by Tim M. — 7. September 2015 @ 10:27

  2. Es ist nicht gedacht, das man diese Extension für NEUE Projekte nutzt, die man mit TYPO3 6.2 macht, sondern es gieng mir mehr darum, dass man eine bestehende TYPO3 Installation von 4.5 auf 6.2 upgraden kann und es dann noch irgendwie läuft. Da ist mein Post vielleicht zu wenig klar. Neue Projekte damit zu machen wird wenig zukunfsicher sein und ich rate sehr davon ab. Leider kann ich dir nicht weiterhelfen, ich verstehe die Fehlermeldung nicht und habe keine Idee an was es liegen könnt.

    Kommentar by Fabian Thommen — 7. September 2015 @ 11:06

RSS feed for comments on this post. TrackBack URL

Leave a comment